foobar2000

Standalone Android APK downloads

These packages are provided for specific usage cases where packages served through Google Play do not work correctly.
In most cases, we recommend that you use Google Play to install foobar2000 mobile on your Android device instead.

Latest stable version

Download: foobar2000 Mobile, v1.5.1 (install correct APK from the archive)
View change log

Latest preview version

Download: foobar2000 Mobile, v1.6 preview 2024-06-18 (install correct APK from the archive)
Read preview change log

System requirements

Android 4.1 or newer.
Android 7.0 or newer for foobar2000 mobile v1.6 preview.
All form factors (phone/tablet/TV) supported.

For old devices

See: old versions of foobar2000.

Go to foobar2000 mobile home page